Back to overview
Downtime
Our Monad nodes are down
Oct 28, 2025 at 3:25pm UTC
Affected services
Marty - RPC
Resolved
Oct 28, 2025 at 6:46pm UTC
Monad update has been successfully applied to all nodes and all services recovered.
Affected services
Updated
Oct 28, 2025 at 6:39pm UTC
Swaps app recovered
Affected services
Updated
Oct 28, 2025 at 6:30pm UTC
The first of our nodes have been fixed
Affected services
Updated
Oct 28, 2025 at 6:17pm UTC
We received a patch from Monad, applying it soon
Affected services
Created
Oct 28, 2025 at 3:25pm UTC
Several monad teams have had their nodes and validators, including us, have lost their connection with the rest of the network.
The Monad team is aware of this issue and we're currently investigating
Affected services