Back to overview

Fixed issue

Feb 20 at 12:13pm EST
Affected services
MACE Swaps API

Resolved
Feb 20 at 12:13pm EST

We have found and resolved the issue with Swaps API. Thanks for your patience!